Unable to run the AMS AECT utility




Can be useful if running the AECT utility

Possible causes and solution(s)

  • Symptoms

When attempting to run the AECT utility to check PC specs, there may occur a situation where it doesn't run at all when selecting run as administrator or just double clicking on it to open it. Typically nothing will appear or possibly a text file may appear like the one in the screenshot below:

image-2023-10-10_8-51-39.png

  • Causes

This may be caused due to windows updates or restrictions.


  • Solution

Here are the steps to a possible solution to this issue:

  1.  Navigate to the downloaded AMS installation folder. Open the EN\AddOns\Advanced\AECT folder.

  2.  Open the "Plugins" folder.

image-2023-10-10_9-10-38.png

   3. In the plugins folder, right click on the AECT.base.dll file and select "properties".

image-2023-10-10_9-15-4.png

  4. On the next screen that appears, check the "Unblock" checkbox on the bottom right.

image-2023-10-10_9-18-10.png

  5. Click "apply" and then "okay" to apply the option and close the screen.

image-2023-10-10_9-20-21.png

   6. Rerun the AECT utility and remember to select "run as administrator".

image-2023-10-10_9-33-32.png

  7. Click on "Allow Access" if any firewall messages appear.

image-2023-10-10_9-35-42.png

  8. You should now be able to run the AECT utility.

image-2023-10-10_9-37-20.png


A more detailed explanation of what causes the issue can be found here.