Possible causes and solution(s)
Symptoms
After upgrading FLEXIDOME IP 3000i IR (NDE-3502-AL) cameras from firmware 7.83.0027 to 7.90.0098, the following error message may appear:
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“RcppSDK: Response timeout”
Additional symptoms:
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The issue occurs on all cameras upgraded from firmware 7.83.0027 to 7.90.0098
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VCA menu is not accessible
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Other menus are really slow or not responsive (both in Configuration Manager and in the camera web browser).
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The issue persists after reboot
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Same behavior is observed:
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when accessing from multiple PCs
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when using different versions of Configuration Manager
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Causes
This issue may occur due to a network or communication problem with the camera.
Solution
To resolve the issue, perform a factory default as this ensures that all firmware changes are fully applied.
If the camera is not accessible after factory default (via web GUI or Configuration manager), perform a hardware reset.
Hardware reset procedure:
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Locate the hardware reset button on the camera block (next to the audio and alarm in / out connectors).
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To access the reset button, remove the camera bubble
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Press and hold the reset button for more than 8 seconds. The red LED indicator on the PCBA board will come on to show that the hardware reset started.
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Wait for the camera complete a self-check. The red LED will turn off once finished.
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Search again for the IP address. Access the camera using the web browser. Set the initial password for the camera.
After performing these steps cameras become accessible again.
Note: If the hardware reset does not restore access to the camera, the cameras has likely encountered a fault that requires the intervention of the RMA repair team.
For more details regarding the RMA process please refer to this article.
Additional Information
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The firmware upgrade from 7.83 → 7.90 does NOT require intermediate versions
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Downgrading back to 7.83 is supported if needed